Nubert XMOS-Stereo-Driver und Windows 11

Fragen und Antworten zu Nubert Aktivlautsprechern
Antworten
Benutzeravatar
Manfred F-B
Newbie
Newbie
Beiträge: 39
Registriert: Di 30. Mär 2021, 15:02
Hat sich bedankt: 30 Mal
Danksagung erhalten: 3 Mal

Nubert XMOS-Stereo-Driver und Windows 11

Beitrag von Manfred F-B »

Ich denke mal, mein Hinweis ist in diesem Forum recht passend aufgehoben.

Ich nutzte meine Aktivboxen unter Windows 10 und unter der Windows 11-Insider-Version schon immer mit dem "XMOS-Stereo-USB-Audio-Class2-Driver-3091_v3.20.0.exe-Treiber". Unter Windows 10 funktionierten nach meiner Erinnerung die Aktivboxen auch ohne diesen Treiber, aber ich hatte ohne Installation stets die bekannten Fragezeichen im Gerätemanager.

Heute nun habe ich die ganz aktuell zur Verfügung stehende Windows 11-Preview-Version als Clean Install vom Boot-Stick aus installiert. Danach habe ich festgestellt, dass mit im BIOS aktiviertem "Secure Boot" der XMOS-Treiber keine Gnade vor dem wachsamen Security-Auge findet und nicht gestartet wird. Die Lautsprecher sind demzufolge auch nicht bei den Soundgeräten aufzufinden.

Mit deaktiviertem "Secure Boot" sind sie dann wieder da und alles läuft gut. Nun soll ja später eigentlich für die finale Windows 11-Version ein aktiviertes "Secure Boot" verpflichtend sein. Da aber sonst bei mir alles super läuft, lasse ich es erst einmal deaktiviert.

Ich würde mich freuen, wenn jemand von den Nubert-Experten diesen Hinweis liest und man ggf. vorausschauend tätig werden kann.
Auf ewig werdender Fortgeschrittener :confusion-helpsign:
Benutzeravatar
R. Steidle
Nubert Staff
Nubert Staff
Beiträge: 2135
Registriert: Mi 23. Okt 2013, 15:25
Hat sich bedankt: 118 Mal
Danksagung erhalten: 307 Mal

Re: Nubert XMOS-Stereo-Driver und Windows 11

Beitrag von R. Steidle »

Für Windows 10 wird der XMOS-Treiber schon lange nicht mehr benötigt und wir empfehlen dessen Installation auch nicht mehr. Die notwendigen Dateien wurden von Microsoft bereits vor längerer Zeit (rund zwei Jahre, wenn ich mich recht entsinne) in Windows integriert, entsprechend werden nuPro X-Lautsprecher beim Anschluss via USB automatisch erkannt und können umgehend verwendet werden. Wie das in Windows 11 laufen wird, können wir noch nicht sagen, aber ich würde vermuten, dass auch dort kein gesonderter Treiber installiert werden muss.
Benutzeravatar
Manfred F-B
Newbie
Newbie
Beiträge: 39
Registriert: Di 30. Mär 2021, 15:02
Hat sich bedankt: 30 Mal
Danksagung erhalten: 3 Mal

Re: Nubert XMOS-Stereo-Driver und Windows 11

Beitrag von Manfred F-B »

Vielen Dank für die schnelle Antwort!

Nun ist ja auch die Win 11-Clean-Install-ISO immer noch keine endgültige Produktivversion und vieles bleibt abzuwarten.

So konnte ich eben auch nur den heutigen Stand durchgeben.

Und da wurden die Nupros eben nicht (oder noch nicht) automatisch erkannt. Mit installiertem Treiber wurden sie nur dann erkannt, wenn im BIOS "Secure Boot" deaktiviert war.

Habe es gerade noch einmal zur Sicherheit getestet, bevor ich geantwortet habe. Dasselbe betrifft übrigens auch den Realtek-Soundmanager, mit dem ich meine Kopfhörer betreibe.

"Secure Boot" aktiv = keine aktiven Treiber mit gelben Warnungen im Gerätemanager, keine Soundgeräte sichtbar.
"Secure Boot" nicht aktiv = alles in Ordnung

Es bleibt also spannend! :D
Auf ewig werdender Fortgeschrittener :confusion-helpsign:
RA-HA
gerade reingestolpert
Beiträge: 3
Registriert: Do 6. Feb 2020, 23:55

Re: Nubert XMOS-Stereo-Driver und Windows 11

Beitrag von RA-HA »

Ich erinnere mich dunkel, dass nach dem Update auf W11 (kein clean install) die NuPros zunächst im Foobar verschwunden waren. Ich meine, dass ich sie dann in den allgemeinen Soundeinstellungen wiedergefunden und aktiviert habe. Jedenfalls funktioniert alles wieder einwandfrei und ohne irgendwelche zusätzliche Treiber. (Surface Pro 6)
hoschig
Newbie
Newbie
Beiträge: 10
Registriert: Do 10. Jan 2013, 08:05
Danksagung erhalten: 1 Mal

Re: Nubert XMOS-Stereo-Driver und Windows 11

Beitrag von hoschig »

Hallo,

seit gestern läuft auf meinem Rechner Win 11 davor war es Win 10.
Seit einiger Zeit schon nutze ich meine nupro-x6000 ohne den XMOS-Treiber. Dies funktionierte auch sofort unter Win 11. Sowohl in der Systemsteuerung als auch in foobar sind die nupros angezeigt worden und waren einsatzbereit.
Die Fragezeichen in der Systemsteuerung sind nach wie vor vorhanden.

Grüße
Rüdiger
hoschig
Newbie
Newbie
Beiträge: 10
Registriert: Do 10. Jan 2013, 08:05
Danksagung erhalten: 1 Mal

Re: Nubert XMOS-Stereo-Driver und Windows 11

Beitrag von hoschig »

Eine Frage an`s Forum habe ich aber noch - hoffe ich bin hier richig:

In Foobar nutze ich als Ausgabe "Wasapi (push)". Wähle ich "Wasapi (event)" kommt der Ton verzerrt.

Hat mir hier jemand einen Tipp? Der Unterschied zwischen push und event ist mir bekannt.
hoschig
Newbie
Newbie
Beiträge: 10
Registriert: Do 10. Jan 2013, 08:05
Danksagung erhalten: 1 Mal

Re: Nubert XMOS-Stereo-Driver und Windows 11

Beitrag von hoschig »

Nachtrag;

Das oben beschriebene Problem besteht nur, wenn das Musikmaterial in 24bit zugespielt wird, bei 16bit tritt der Fehler nicht auf.
hoschig
Newbie
Newbie
Beiträge: 10
Registriert: Do 10. Jan 2013, 08:05
Danksagung erhalten: 1 Mal

Re: Nubert XMOS-Stereo-Driver und Windows 11

Beitrag von hoschig »

hoschig hat geschrieben: Do 7. Okt 2021, 18:21 Eine Frage an`s Forum habe ich aber noch - hoffe ich bin hier richig:

In Foobar nutze ich als Ausgabe "Wasapi (push)". Wähle ich "Wasapi (event)" kommt der Ton verzerrt.

Hat mir hier jemand einen Tipp? Der Unterschied zwischen push und event ist mir bekannt.
Das Problem ist gelöst seit ich den XMOS USB Treiber installiert habe und nicht mehr den Windows eigenen Treiber verwende.
8)
Benutzeravatar
R. Steidle
Nubert Staff
Nubert Staff
Beiträge: 2135
Registriert: Mi 23. Okt 2013, 15:25
Hat sich bedankt: 118 Mal
Danksagung erhalten: 307 Mal

Re: Nubert XMOS-Stereo-Driver und Windows 11

Beitrag von R. Steidle »

Danke fürs Ausprobieren!
hoschig
Newbie
Newbie
Beiträge: 10
Registriert: Do 10. Jan 2013, 08:05
Danksagung erhalten: 1 Mal

Re: Nubert XMOS-Stereo-Driver und Windows 11

Beitrag von hoschig »

Gerne!
Mit dieser Konfiguration habe ich auch keine Fragezeichen mehr in der Systemsteuerung.
Antworten